VXLAN Flood & Learn on Nexus 9kv with GNS3 2.1

Configuration for Leaf Switches 1 & 2 and Spine Switches 1 & 2.

Leaf Switch 1 Config
feature ospf
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

vlan 1,192
ip pim rp-address 10.0.0.255 group-list 224.0.0.0/4
ip pim anycast-rp 10.0.0.255 10.0.255.1
ip pim anycast-rp 10.0.0.255 10.0.255.2
vlan 192
  vn-segment 192000

interface nve1
  no shutdown
  source-interface loopback255
  member vni 192000 mcast-group 224.192.16.0

interface Ethernet1/1
  no switchport
  medium p2p
  no ip redirects
  ip unnumbered loopback255
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  no shutdown

interface Ethernet1/2
  no switchport
  medium p2p
  no ip redirects
  ip unnumbered loopback255
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  no shutdown

interface Ethernet1/9
  switchport access vlan 192
  spanning-tree port type edge

interface loopback255
  ip address 10.0.255.3/32
  ip ospf network point-to-point
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  ip igmp join-group 224.1.1.1

boot nxos bootflash:/nxos.7.0.3.I5.2.bin
router ospf 255
  router-id 10.0.255.3
  log-adjacency-changes

Leaf Switch 2 Config

feature ospf
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

vlan 1,192
ip pim rp-address 10.0.0.255 group-list 224.0.0.0/4
ip pim anycast-rp 10.0.0.255 10.0.255.1
ip pim anycast-rp 10.0.0.255 10.0.255.2
vlan 192
  vn-segment 192000

interface nve1
  no shutdown
  source-interface loopback255
  member vni 192000 mcast-group 224.192.16.0

interface Ethernet1/1
  no switchport
  medium p2p
  no ip redirects
  ip unnumbered loopback255
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  no shutdown

interface Ethernet1/2
  no switchport
  medium p2p
  no ip redirects
  ip unnumbered loopback255
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  no shutdown

interface Ethernet1/9
  switchport access vlan 192
  spanning-tree port type edge

interface loopback255
  ip address 10.0.255.4/32
  ip ospf network point-to-point
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  ip igmp join-group 224.1.1.1

boot nxos bootflash:/nxos.7.0.3.I5.2.bin

router ospf 255
  router-id 10.0.255.4
  log-adjacency-changes

Spine Switch 1 Config

feature ospf
feature pim

ip pim rp-address 10.0.0.255 group-list 224.0.0.0/4
ip pim anycast-rp 10.0.0.255 10.0.255.1
ip pim anycast-rp 10.0.0.255 10.0.255.2
vlan 1

interface Ethernet1/1
  no switchport
  medium p2p
  no ip redirects
  ip unnumbered loopback255
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  no shutdown

interface Ethernet1/2
  no switchport
  medium p2p
  no ip redirects
  ip unnumbered loopback255
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  no shutdown

interface loopback1
 ip address 10.0.0.255/32
  ip ospf network point-to-point
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode

interface loopback255
  ip address 10.0.255.1/32
  ip ospf network point-to-point
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  ip igmp join-group 224.1.1.1

boot nxos bootflash:/nxos.7.0.3.I5.2.bin
router ospf 255
  router-id 10.0.255.1
  log-adjacency-changes

Spine Switch 2 Config

feature ospf
feature pim

ip pim rp-address 10.0.0.255 group-list 224.0.0.0/4
ip pim anycast-rp 10.0.0.255 10.0.255.1
ip pim anycast-rp 10.0.0.255 10.0.255.2
vlan 1

interface Ethernet1/1
  no switchport
  medium p2p
  no ip redirects
  ip unnumbered loopback255
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  no shutdown

interface Ethernet1/2
  no switchport
  medium p2p
  no ip redirects
  ip unnumbered loopback255
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  no shutdown

interface loopback1
 ip address 10.0.0.255/32
  ip ospf network point-to-point
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode

interface loopback255
  ip address 10.0.255.2/32
  ip ospf network point-to-point
  ip router ospf 255 area 0.0.0.1
  ip pim sparse-mode
  ip igmp join-group 224.1.1.1

boot nxos bootflash:/nxos.7.0.3.I5.2.bin
router ospf 255
  router-id 10.0.255.2
  log-adjacency-changes

Test from PC1->PC2 and PC2->PC1

PC1> ping 192.168.1.2 -c 3
84 bytes from 192.168.1.2 icmp_seq=1 ttl=64 time=19.514 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=64 time=41.914 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=64 time=50.067 ms

PC2> ping 192.168.1.1 -c 3
84 bytes from 192.168.1.1 icmp_seq=1 ttl=64 time=63.936 ms
84 bytes from 192.168.1.1 icmp_seq=2 ttl=64 time=36.437 ms
84 bytes from 192.168.1.1 icmp_seq=3 ttl=64 time=72.507 ms

Network Architect | CCIEx3 #29824 JNCIE #2197 VCIX-NV